Statistics display issue
Incident Report for Batch
Resolved
We resolved our issue. All statistics displays are back to normal.
Posted Feb 17, 2020 - 12:52 UTC
Update
We are continuing to investigate this issue.
Posted Feb 17, 2020 - 11:21 UTC
Investigating
Our team detected an issue impacting the display of campaigns stats on the dashboard. We're investigating it and will keep you posted.
Posted Feb 17, 2020 - 10:52 UTC
This incident affected: Dashboard (Main dashboard, Editorial dashboard).