Email Campaign and Recurring Automation slowdown
Incident Report for Batch
Resolved
This incident has been resolved.
Posted Dec 20, 2023 - 22:31 UTC
Monitoring
The issue has been resolved, we will keep monitoring the services for a while.
Posted Dec 20, 2023 - 20:07 UTC
Identified
We have identified an issue on email campaigns & recurring automations:
Their execution has been slowed down since 18:00 GMT+1. Some emails will not be sent.

Trigger emails are not affected.
Posted Dec 20, 2023 - 19:29 UTC
This incident affected: Delivery (Email automations, Email campaigns).