This incident has been resolved. The exports have been back up since 09:45 CET, pending requests are still being processed.
Posted Mar 23, 2026 - 10:29 UTC
Monitoring
MEP campaign delivery has been restored. Campaigns planned since 22:45 CET are currently being sent, and the MEP Audiences API is back to normal. We are monitoring the platform to ensure stability. CEP export slowdowns (recurring and API) remain under investigation.
Posted Mar 23, 2026 - 00:15 UTC
Identified
We have identified the root cause of this incident. A failure on a subset of our infrastructure servers is preventing MEP campaigns from being sent and the MEP Audiences API from responding. CEP exports are also experiencing slowdowns on some jobs as a secondary effect. Our team is actively working on restoring the affected services.
Posted Mar 22, 2026 - 23:42 UTC
Investigating
We are experiencing an infrastructure issue impacting parts of our platform. Campaign sending on MEP and the MEP Audiences API have been unavailable since 22:45 CET. CEP exports (recurring and API) have been experiencing slowdowns on some jobs since 23:10 CET.
Other platform features are operating normally. Our team is actively working on restoring service.
Posted Mar 22, 2026 - 22:31 UTC
This incident affected: MEP Core Services (Push delivery), Optional Services (Custom Exports), and API ([CEP] Export API).