Push delivery and data processing issues
Incident Report for Batch
Resolved
This incident has been resolved.
Posted Jun 29, 2022 - 15:01 UTC
Monitoring
The issue has been identified and a fix has been implemented. Data is now being processed without significant delay. Push notifications scheduled in classic or trigger push campaigns are being delivered correctly. Our engineers are monitoring the situation.

Here are more details on the impact of the incident:
- Data processing: Data collected during the incident have not been lost and is being indexed. Some trigger events tied to Trigger campaigns have been skipped.
- Push delivery: New installs, tokens and custom user ID were being indexed with delays. This resulted in delivery delays impacting new users or users targeted using their custom user ID (e.g. via the Transactional API or Custom Audiences).
Posted Jun 29, 2022 - 13:38 UTC
Investigating
We are currently experiencing an issue impacting:
- Data processing: Install and user data may be processed with a ~15 minute delay. Some events tied to active trigger campaigns may be skipped (e.g. trigger or cancellation events).
- Push delivery: We are also aware of problems impacting push delivery. Our engineers are currently evaluating the impact.

We will post updates here as soon as the cause of the incident is identified.
Posted Jun 29, 2022 - 12:04 UTC
This incident affected: Delivery (Transactional push, Push campaigns) and Webservices (Custom attributes).