Delays in CEP automation triggers (Push, Email & SMS)

Incident Report for Batch

Resolved

This incident has been resolved.
Posted Aug 07, 2025 - 10:25 UTC

Monitoring

We have rolled back the database maintenance operation, and all automation triggers have now processed their backlog.

All CEP campaigns with Push, Email & SMS are now back online.

We are actively monitoring the situation and will provide further updates as we progress.
Posted Aug 07, 2025 - 10:12 UTC

Identified

Following a maintenance operation on our data‑storage system, CEP automation triggers have been processing more slowly than expected.

Our engineering team is analysing the issue and working to restore normal performance.

We will provide further updates as soon as we have more information.
Posted Aug 07, 2025 - 09:21 UTC
This incident affected: CEP Core Services (Email delivery, Push Delivery, SMS Delivery).