Hosting provider networking issue

Incident Report for Batch

Postmortem

At 7:47PM a network component of our hosting provider went down for 10 minutes. We acknowledged this on our side : no input traffic, no output traffic, and some internal services were unavailable during this period.

What was the impact :

  • we were unable to respond for all input traffic on our API
  • the SDK couldn’t reach our backend, but we have a strong retry policy
  • some push were retried however some were still not sent
  • processing of data are still running late, but everything will be up-to-date in less than 10min now
Posted Mar 18, 2020 - 20:43 UTC

Resolved

According to our hosting provider, all services are back to normal. A post-mortem will follow.
Posted Mar 18, 2020 - 20:20 UTC

Identified

A component on our hosting provider's side seems to be impacting our production trafic. We're not yet able to clearly identify our production impact. Therefore we assume all components are down and are actively working towards a stable situation.
Posted Mar 18, 2020 - 20:03 UTC

Update

We are continuing to investigate this issue.
Posted Mar 18, 2020 - 19:55 UTC

Investigating

We're currently aware of a wide network issue, we're not yet aware of all impacted component and will keep you informed here.
Posted Mar 18, 2020 - 19:54 UTC
This incident affected: [OLD_STATUSPAGE_MODEL] 3rd party integrations (Segment, mParticle, Salesforce Marketing Cloud), MEP Core Services (Dashboard, In-app delivery, Data ingestion), Optional Services (Editorial dashboard, Inbox, Custom Exports), [OLD_STATUSPAGE_MODEL] Delivery (Transactional push, Push campaigns, In-app messaging), [OLD_STATUSPAGE_MODEL] Webservices (Custom attributes, Web push static resources), and API ([MEP] Campaigns API, [MEP] Transactional API, [MEP] Custom Data API, [MEP] Transactional API for Partners).