Incorrect Date Attribute Values on Some CEP Profiles

Incident Report for Batch

Resolved

The data has been restored:

* Targetings using those attributes will now work as expected
* The attributes now show up in the Profile View
* Future exports will show the correct data


We will not replay automations & campaigns to profiles that should have been targeted but were not. Future occurrences will work as expected.
Posted Jul 04, 2025 - 10:39 UTC

Identified

We have identified an issue affecting Date attributes on Profiles when updated via our SDKs (v2.x and v3.x).
Between July 2nd, 15:36 CET and July 3rd, 15:25 CET, any Date attribute set using the SDK was assigned an incorrect value far in the future.


Impact
As a result of this issue:

* Targeting based on these attributes will not behave as expected.
* Profiles will not appear correctly in the Dashboard’s Profile View.
* Data exports will reflect incorrect dates for affected attributes.



What is Not Affected

* Attributes updated outside the impacted time window have the correct value.
* Attributes updated via the Profile API or Custom Data API are not impacted.
* The MEP (Mobile Engagement Platform) remains unaffected.


Current status
Our engineering team is actively working on restoring the correct values for all impacted Profiles. As it is a lengthy process, we expect this work to be completed in the next 24h.
Posted Jul 03, 2025 - 17:04 UTC