Dashboard and campaigns analytics issues

Incident Report for Batch

Resolved

This incident has been resolved.
Posted Jul 07, 2022 - 15:28 UTC

Monitoring

The issue has been fixed: app, campaigns analytics and campaign estimates are now working as expected. No data has been lost. Our engineers are monitoring the situation.
Posted Jul 06, 2022 - 10:50 UTC

Investigating

We are currently experiencing an issue affecting the display of app and campaigns analytics on Batch dashboard and campaigns estimates. Our team is investigating the issue.
Posted Jul 06, 2022 - 08:39 UTC
This incident affected: MEP Core Services (Dashboard).