Email delivery issues
Incident Report for Batch
Resolved
The email service is back online. Emails scheduled from yesterday at 9:00 UTC will not be resent. Our delivery team will continue to monitor the performance indicators of the campaigns over the next few days to ensure the service is working as expected.
Posted Apr 18, 2023 - 07:57 UTC
Monitoring
A fix has been implemented. Batch email service remains suspended until all the pending emails are sent. Our delivery team is currently monitoring the situation.
Posted Apr 17, 2023 - 12:15 UTC
Identified
The issue has been identified and our team is currently working on a fix. A small portion of targeted users may have received several duplicated emails during the incident.
Posted Apr 17, 2023 - 11:05 UTC
Investigating
Our engineering team is currently investigating an issue impacting our email service. Our engineering team has momentarily suspended the delivery of new emails during the investigation. We will post updates here on the resolution of the issue.
Posted Apr 17, 2023 - 09:01 UTC