Dashboard Performance Issue

Incident Report for Batch

Resolved

Situation is back to normal
Posted May 20, 2025 - 13:22 UTC

Monitoring

The performance issues previously affecting the dashboard have been resolved. A fix has been applied, resulting in a much faster experience for all users. We will continue to monitor the situation to ensure everything remains stable.
Posted May 20, 2025 - 09:42 UTC

Investigating

We are currently experiencing slowness on our dashboard. Our teams are investigating the cause of this issue. We will keep you updated on the situation.
Posted May 20, 2025 - 09:27 UTC
This incident affected: MEP Core Services (Dashboard), Optional Services (Editorial dashboard), and CEP Core Services (Dashboard).