Database issues impacting data indexing and Trigger campaigns
Incident Report for Batch
Resolved
This incident has been resolved.
Posted Aug 31, 2022 - 08:21 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 30, 2022 - 12:00 UTC
Identified
The issue has been identified and we have implemented a partial fix:
- Push tokens and custom data: No data has been lost. We are currently catching up the indexing delays.
- Trigger campaigns: Events are processed with a delay, but the event is indexed with its actual timestamp. Depending on the timer of the Trigger campaign, the notifications may be delivered later than expected.

The “Last push date” and “Last visit date“ attributes are not indexed. We are working on a fix and will update you once it is solved.
Posted Aug 26, 2022 - 15:56 UTC
Investigating
We're currently experiencing some issues with our databases which is impacting the indexing of:
- Push tokens
- Custom data (custom attributes and custom tag collections)
- The “Last push date” and “Last visit date“ attributes

Trigger campaigns execution is also impacted.

We will update you as soon as we have more information and the next steps.
Posted Aug 26, 2022 - 08:00 UTC
This incident affected: Delivery (Push campaigns) and Webservices (Custom attributes).