Issue creating/updating campaigns with images
Incident Report for Batch
Resolved
Our team is aware of a minor issue occuring when campaigns with images are created or updated. Running campaigns with images aren't affected. We are investigating the matter.
Posted Oct 10, 2019 - 09:10 UTC