Dashboard unreachable

Incident Report for Batch

Resolved

This incident has been resolved.
Posted Jul 07, 2025 - 10:14 UTC

Update

Dashboard is back online, we are still investigating.
Posted Jul 07, 2025 - 10:09 UTC

Update

We are continuing to investigate this issue.
Posted Jul 07, 2025 - 10:06 UTC

Update

We are currently investigating a network issue that is affecting access to the main dashboard. Our engineering team is actively working to identify the root cause and restore normal service as quickly as possible.
Posted Jul 07, 2025 - 10:06 UTC

Update

We are continuing to investigate this issue.
Posted Jul 07, 2025 - 09:59 UTC

Investigating

We are currently investigating this issue.
Posted Jul 07, 2025 - 09:58 UTC
This incident affected: MEP Core Services (Dashboard), CEP Core Services (Dashboard), and API ([CEP] Audience API).