Email composer unavailable on Batch dashboard
Incident Report for Batch
Resolved
The fix has been released at 12:50pm UTC and the email composer is now working as expected.
Posted Jul 22, 2024 - 12:57 UTC
Identified
Our Email Composer partner is currently facing issues affecting the availability of the Email Composer feature on the Batch dashboard. Consequently, creating or modifying email templates is not possible at the moment.

The issue has been identified, and a fix is being prepared. Our partner's team is working diligently to resolve the problem and restore full functionality. We will provide an update once the fix is deployed or if there are any significant developments.

We apologize for the inconvenience and appreciate your patience.
Posted Jul 22, 2024 - 11:55 UTC
This incident affected: Dashboard (Main dashboard).