Image loading issues

Incident Report for Batch

Resolved

This incident has been resolved.
Posted Jun 28, 2025 - 09:52 UTC

Monitoring

A fix has been implemented. We haven't observed any new issues for the past two hours and will continue to monitor the situation closely.
Posted Jun 27, 2025 - 10:18 UTC

Update

We're still observing intermittent image loading errors, though at a significantly reduced rate compared to the last 24 hours. The last reported error occurred at 15:00 CET.

Our team continues to actively work on implementing a permanent fix.
Posted Jun 26, 2025 - 16:26 UTC

Identified

We're currently experiencing intermittent errors with our image loading system.

The impact is two fold:

* some campaigns cannot be created correctly due to image loading failures, affecting both the main dashboard and the editorial dashboards.
* some transactional push notifications containing images cannot be sent correctly due to image loading failures.

This issue started on June 20th at 17:00 CET.

Our team is actively investigating the issue and working to restore full functionality as quickly as possible. We apologize for any inconvenience this may cause.
Posted Jun 26, 2025 - 08:31 UTC
This incident affected: MEP Core Services (Dashboard, Push delivery), Optional Services (Editorial dashboard), and CEP Core Services (Dashboard, Push Delivery).