Marketing Pressure Calculation Delays
Incident Report for Batch
Resolved
This incident has been resolved.
Posted Feb 16, 2024 - 16:12 UTC
Monitoring
A fix has been implemented and we are back to normal. We will keep monitoring the situation.
Posted Feb 16, 2024 - 14:06 UTC
Identified
Our team is aware of calculation delays impacting the marketing pressure feature.

Push notifications very close to each other to the same install may be delivered regardless of the marketing pressure rules set in Batch dashboard. We are working on a resolution.
Posted Feb 16, 2024 - 13:58 UTC