Profile update processing delays on CEP

Incident Report for Batch

Update

Recovery is nearly complete on our CEP profile processing pipeline, with real-time processing restored for the large majority of profile updates. We expect the remaining delay to fully clear during this evening. As a precaution, we have put in place reinforced monitoring and on-call coverage overnight to quickly detect and address any recurrence. We will share a further update tomorrow morning.
Posted Jul 07, 2026 - 16:32 UTC

Update

Recovery is underway on our CEP profile processing pipeline. Real-time processing has been restored for approximately 99% of profile updates, and the remaining share is still catching up. During this time, a small portion of attribute updates may still be delayed in one-time & recurring campaign targeting, automations triggered by attribute changes, and profile analytics. No data has been lost, and all delayed updates will be processed as the backlog clears.
Posted Jul 07, 2026 - 15:21 UTC

Monitoring

We are seeing recovery on our CEP profile processing pipeline. Real-time processing has already been restored for the majority of profile updates, while a subset is still catching up, so some attribute updates may remain delayed a bit longer in one-time & recurring campaign targeting, automations triggered by attribute changes, and profile analytics. No data has been lost, and all delayed updates will be processed as the backlog clears. We are continuing to monitor closely until processing is fully back to real time.
Posted Jul 07, 2026 - 10:05 UTC

Investigating

Since approximately 04:40 CEST, our CEP profile processing pipeline has been delayed, with profile updates currently around 5 hours behind real time. As a result, some profile attribute updates may not yet be reflected in one-time & recurring campaign targeting, automations triggered by attribute changes, and profile analytics. Campaign audience selection and most event-based automations are not affected. We are actively investigating the issue; no data has been lost, and delayed updates will be processed as the backlog clears.
Posted Jul 07, 2026 - 08:35 UTC
This incident affects: CEP Core Services (Data ingestion).