Error rate increase when sending Android notifications
Incident Report for Batch
Resolved
It appears the bug has been fixed by FCM at some point the 2021-01-23, we are no longer seeing elevated error rates.
Posted Jan 23, 2021 - 17:01 UTC
Monitoring
We identified a problem when sending Android notifications to the FCM push service.

Since the 2021-01-18 we've seen an increase in errors of the type "invalid_parameters" returned by FCM for some customers. Following our investigation we've determined that this is due to a bug in the FCM push service itself.

The root cause of this issue is that FCM started disallowing the `aps` key in the request payload: for our customers this key can appear in the `custom_payload` field, for example:

{"aps": {"badge": 1}}

This will be integrated in the notification payload and unfortunately FCM is currently rejecting this.

We suggest removing the `aps` object temporarily if it is not absolutely necessary for your app to work correctly.

Unfortunately, this is not something we have control over, we can only wait for Google to fix its bug upstream.
We will update this incident when we are sure the bug is fixed upstream.
Posted Jan 21, 2021 - 15:55 UTC
This incident affected: Delivery (Transactional push, Push campaigns).