Email campaign & recurring automations delivery delay
Incident Report for Batch
Resolved
This incident has been resolved.
Posted Apr 02, 2024 - 15:09 UTC
Monitoring
The root cause has been identified: a huge number of Email campaigns has been created at once, creating a spike that overloaded the systems.

As opposed to what was initially reported, Email campaigns & recurring automations were not stuck but slowly sending.
The system is catching up and is progressively sending the emails that should have been sent since the beginning of this incident.

We are monitoring the situation.
Posted Apr 02, 2024 - 13:00 UTC
Investigating
Email campaigns & Recurring Automations have not been sent since 11:10 AM UTC
We are currently investigating this issue.
Posted Apr 02, 2024 - 12:19 UTC
This incident affected: Delivery (Email automations, Email campaigns).