Delays in CEP campaign processing

Incident Report for Batch

Resolved

The service has been restored and has been under monitoring for 48 hours with no regressions observed.
Posted Mar 04, 2026 - 07:35 UTC

Monitoring

CEP campaigns (one-shot and recurring automations) are back to normal. The backlog was fully processed at 16:25 CET, and campaigns sent as of now work as expected.

No data has been lost.
Posted Feb 28, 2026 - 15:31 UTC

Identified

We are investigating delays affecting CEP campaigns (one shot & recurring).
As of writing, processing is approximately 1 hour behind schedule.
In-app messages and automations are not affected.

Campaigns will be sent to the expected users as the backlog clears.
Posted Feb 28, 2026 - 15:02 UTC
This incident affected: CEP Core Services (Email delivery, Push Delivery, SMS Delivery).