Email Composer – Service Unavailable

Incident Report for Batch

Resolved

This incident has been resolved. Between 15:28 CEST and 15:57 CEST, our email composer provider experienced degraded performance on their infrastructure, which impacted plugin initialization in the email editor. A fix was deployed on the provider side and service is back to normal.
Posted Apr 21, 2026 - 14:04 UTC

Identified

Since April 21 at 15:28 CEST, the Email Composer is unavailable due to an incident on our third-party provider's side (Stripo). Users are unable to access or edit email messages in the composer at this time.
The issue has been escalated to Stripo, and we are actively monitoring their progress toward a fix. We will share further updates as soon as more information becomes available.
Posted Apr 21, 2026 - 13:35 UTC
This incident affected: CEP Core Services (Dashboard).