Email Composer - Image Upload Issue

Incident Report for Batch

Resolved

This incident has been resolved.
Posted Feb 19, 2026 - 09:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 19, 2026 - 09:38 UTC

Investigating

We are currently experiencing an issue with our email composer provider that prevents image uploads from functioning correctly.

The issue has been escalated to the provider, and we are awaiting a fix on their side.

We will share further updates as soon as more information becomes available.
Posted Feb 19, 2026 - 09:30 UTC