Monitoring has confirmed that the issue is fully resolved and all systems are operating normally. This incident is now closed.
Posted Mar 28, 2025 - 09:23 UTC
Update
A permanent fix has been implemented, and the affected components remain stable. The incident will remain open as we continue to closely monitor the situation for the next 24 hours.
Posted Mar 27, 2025 - 16:10 UTC
Update
There are no changes at this time. The mitigation remains effective, the impacted components are stable, and we are continuing to monitor the situation closely.
Posted Mar 26, 2025 - 18:36 UTC
Monitoring
A mitigation has been implemented and is functioning as expected. We are continuing to closely monitor the system and address any remaining issues.
Posted Mar 25, 2025 - 14:47 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 25, 2025 - 14:02 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2025 - 13:44 UTC
Investigating
We’re currently experiencing connectivity issues affecting the Dashboard. Our team is investigating and working to restore full access as soon as possible.
Posted Mar 25, 2025 - 13:44 UTC
This incident affected: MEP Core Services (Dashboard), CEP Core Services (Dashboard), and API ([CEP] Campaign API, [MEP] Campaigns API, [MEP] Custom Audience API).