Profile updates and custom events processing delays on CEP

Incident Report for Batch

Resolved

Data ingestion has fully caught up. Everything is back to normal.
Posted Jun 20, 2025 - 09:45 UTC

Update

We are continuing to monitor for any further issues.
Posted Jun 20, 2025 - 09:44 UTC

Update

The data ingestion delay has been cleared for:

* Profile attribute updates
* Custom events from the API and web SDKs

We are still working on catching up with data ingestion from the mobile SDKs.

We will provide an update as soon as everything is back to normal.
Posted Jun 20, 2025 - 07:01 UTC

Monitoring

A fix has been implemented. We are currently handling the data ingestion queue.
Posted Jun 20, 2025 - 06:54 UTC

Investigating

We are currently experiencing a delay in indexing messages from our SDKs and Profile API calls.

At the moment, message indexing is running approximately 8 hours behind. This delay impacts only the updating of Profile events and attributes. Specifically:
• The profile view is not updated in real-time.
• Some automations may be triggered later than expected.
Posted Jun 20, 2025 - 06:14 UTC
This incident affected: API ([CEP] Profile API) and CEP Core Services (Data ingestion).