Instability of API Custom Audience
Incident Report for Batch
Postmortem

Dear Customers,

Our API Custom Audiences feature faced instabilities between 10:45 AM and 12:18 PM UTC, on 26/03/24. This led to intermittent disruptions in service. We understand the impact this may have had on your operations and sincerely apologize for any inconvenience caused.

Incident Summary: During the specified timeframe, our monitoring systems detected irregularities within the API Custom Audiences feature. This led to intermittent disruptions in service, impacting the ability to utilize this functionality seamlessly.

Cause: The instability was caused by an unusual spike in server resource utilization coupled with a temporary bottleneck in data processing. This unexpected surge caused intermittent timeouts and delays in API responses, leading to the observed instability.

Actions Taken: Our engineering team promptly initiated troubleshooting procedures to identify and mitigate the issue. Immediate steps were taken to alleviate the strain on our servers and optimize data processing mechanisms to restore normal functionality as swiftly as possible.

Preventive Measures: We're enhancing monitoring systems and reviewing infrastructure to identify potential scalability improvements to accommodate future growth effectively.

Next Steps: We're committed to maintaining the reliability and stability of our platform. We will persist in improving our services to ensure a smooth experience and apologize for any inconvenience caused.

For inquiries, please contact our support team.

Posted Mar 26, 2024 - 16:10 UTC

Resolved
This incident has been resolved.
Posted Mar 26, 2024 - 12:18 UTC
Update
We are continuing to work on a fix for this issue.
Posted Mar 26, 2024 - 12:00 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 26, 2024 - 10:53 UTC
Investigating
We are currently investigating this issue.
Posted Mar 26, 2024 - 10:45 UTC